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Google Sheets – Introduction  
 

Class Objectives 

 What you can do with Sheets  Adding Sheets  

 Formatting Cells  Formulas / Functions 

 Moving and Selecting Cells  Charts 

 Rows and Columns  Sorting 

 Resizing Rows and Columns  Autofill 

 Freezing Rows and Columns  Themes 

  

Google Sheets 

Google Sheets is Google's equivalent of Microsoft Excel. Files are saved in the cloud on Google Drive 

under your Google account. You can keep the file to yourself or share it with others to view or edit along 

with you. You can even use it on your phone or tablet with the Sheets app, although it’s easier to use on 

a desktop. Almost everything you can do in Excel you can do with Sheets, if perhaps a little differently. 

 

Google Sheets allows you to create spreadsheets much like paper ledgers that can perform automatic 

calculations. Each Google Sheets file is a spreadsheet that can hold many sheets. The sheet is a grid of 

columns (designated by letters) and rows (designated by numbers). The letters and numbers of the 

columns and rows (called labels) are displayed in gray buttons across the top and left side of the sheet. 

The intersection of a column and a row is called a cell. Each cell on the spreadsheet has a cell address 

that is the column letter and row number. Cells can contain text, numbers, or mathematical formulas.  

Column letters 
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Google Sheets Screen Elements 

There are usually at least 3 different ways to do an action. We will mostly be covering the Menu or 

Toolbar options, since those are easiest to demonstrate in class. You can also right-click to bring up a 

menu that is relevant to the element you've clicked on. There are also keyboard shortcuts that you may 

be familiar with from other programs. You can see the keyboard shortcuts in the menu next to the 

action, or search for one by pressing CTRL+/ (control key plus forward slash key).  

 

Here's a quick overview of the Menu Options. 

 

File - For changes you want to make to the file itself. You can Share it, create a New one, Open an 

existing one, Import data from another location, Download it, look at the Version History, Rename it, 

Move to Trash (delete), Print it and many other similar things under this menu. 

 

Edit - Here you will find Undo and Redo for undoing and redoing typing or other actions. Cut, Copy, 

Paste and Paste Special (These only work in Google Chrome, not other browsers). Find and Replace to 

find information you've entered, and Delete to delete cells, rows, columns, etc. 

 

View - This menu controls how things look on your screen. You can Freeze rows and columns, and toggle 

the display of Gridlines, Protected Ranges, and the Formula Bar. Show Formulas instead of the results 

of those formulas, view Hidden Sheets, adjust the Zoom, or go Full Screen. 

 

Insert - Whenever you want to Insert a new element, check here. Notable things you can insert are 

Rows, Columns, Charts, Images, Functions, Links, Comments, and Notes. Pivot Tables are also under 

here. 

 

Format - Sometimes you need to tell Sheets what type of data it is you've entered (text, currency, a 

date, etc.). That's under Number on the Format menu. Also here are Font Size and styles, Text 

Wrapping and things like that. Conditional Formatting allows you to tell Sheets to automatically format 

data a certain way, such as display all negative numbers in red text. 

 

Data - This menu has options for manipulating the data. Go here to Sort or Filter.  

 

Tools - Spell Check and more advanced features can be found here. Accessibility Settings are also here, 

for screen reader or magnifier options. 

 

Extensions - Add-Ons are here. They’re special programs you can download and add to your Google 

Sheets account to help you do other features that are not built-in to Sheets. You can Get and Manage 

them here, and if you've added one, it will show up under this menu. Macros are also here. Those are 

scripts you can create to repeat a set of actions. 
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Help - You can find Help here. Use Function List to see a full list of available functions. You may also be 

interested in looking at what Keyboard Shortcuts you can use. 

 

Moving and Selecting Cells 

You can use your mouse to click on any cell on your worksheet. This will select the cell. From there you 

can either format the cell or add data to the cell. You can also use your mouse to select and highlight a 

range of cells by clicking on a cell and dragging the mouse over the rest of the cells you’d like to select. 

When you finish selecting your cells you can let go of the mouse button. For keyboard strokes which let 

you move through and select cells, see the tables below. 

Cursor Movement 

One cell up Up arrow or SHIFT+Enter 

One cell down Down arrow or Enter 

One cell right Right arrow or Tab 

One cell left Left arrow or SHIFT+Tab 

Top of 

worksheet (cell 

A1) 

CTRL+Home 

End of row End 

End of sheet CTRL+End 

Any cell Help->Search for 'Go to 

Range', then type in the cell 

address 

Move to next 

worksheet 

ALT+Down arrow 

  

 
Selecting Cells 

One cell Click once in the cell 

Entire 

column 

Click the column label 

Entire row Click the row label 

Entire 

worksheet 

Click the whole sheet button or 

CTRL+A twice 

Cluster of 

cells 

Drag mouse over the cells or hold 

down the SHIFT key while using the 

arrow keys 

Non-

adjacent 

cells 

Hold down the CTRL key and use 

the mouse to click on non-adjacent 

cells 
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Moving and Copying Cells 

Action Using the Menu 

(Only works in 

Chrome) 

Using the right mouse button 

(Only works in Chrome) 

Using the 

keyboard 

To cut the cell’s content that will 

be moved to another cell, highlight 

the cell and … 

Edit -> Cut Right click on the highlighted cell, 

select Cut from the menu that 

appears. 

CTRL + X 

To copy the cell’s content, 

highlight the cell and … 

Edit -> Copy Right click on the highlighted cell, 

select Copy from the menu that 

appears. 

CTRL + C 

Highlight the cell into which you 

want to paste the cut or copied 

cell and … 

Edit -> Paste Select Paste from the menu that 

appears. 

CTRL + V 

Highlight the cell into which you 

want to paste values and ... 

Edit -> Paste Special 

-> Paste Values 

Only 

Select Paste Special -> Paste 

Values Only from the menu that 

appears. 

CTRL + SHIFT 

+ V  

Drag and Drop Drag the highlighted border of the selected cell to the destination 

cell with the mouse. 

 

Formatting Sheets 

Adding Rows, and Columns 

Highlight the cell, row or column where you’d like to make the insert. Choose Insert from the menu and 

select Rows->Insert 1 row above or Rows->Insert 1 row below or Columns->Insert 1 column left or 

Columns->Insert 1 column right. 

 

Adding Sheets  

Click on Insert in the menu and select Sheet. Or click on the + on the bottom to the left of the Sheets.  

 

Formatting Cells  

Click on one cell or highlight multiple cells to be formatted.  You can use the icons and shortcuts on the 

toolbar to change the Font (e.g. color of the font, fill of the background, underline/outline of the 

selected cells), Alignment or the way the data inside the cells is displayed.   
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Also, clicking on the button with the $ will format all selected cells which 

contain numbers to be displayed with a dollar sign and two decimal 

places.  Clicking on 123 will give you more data formatting options.     

 

Resizing Rows and Columns 

There are several ways to resize rows and columns: 

1. Resize a row by dragging the line below the label of the row you would like to resize. Resize a 

column in a similar manner by dragging the line to the right of the label corresponding to the 

column you want to resize.   

— OR — 

2. Select a row or column by clicking on its number or letter and then right-click. Choose Resize 

Row or Resize Column from the popup menu. Enter a number or select Fit to data and hit OK. 

— OR — 

3. Hover over the row number or column letter until the arrow appears and 

click on the arrow. Then select Resize Row or Resize Column as in option 

2. 

— OR — 

4. Select the column or row and then double-click on the line separating its 

label from the next label. This will make the column or row as wide or as deep as it currently 

needs to be (aka Fit to Data). 

 

Freezing  

If you have a large worksheet with column and row headings, these headings will not be visible when 

you scroll down or to the right. Sheets provides a handy solution to this problem: freezing. Freezing 

keeps the headings visible while you’re scrolling through the sheet. 

 

You can freeze rows or columns, or both. To freeze a row, select View then Freeze then 1 row or 2 rows. 

1 row will freeze the top row, 2 rows will freeze the top two rows. Select Up to current row to freeze all 

rows above and including the row you have selected. 

 

To freeze a column, select View then Freeze then 1 column, 2 columns, or Up to current column. 

Sheets inserts dark lines to indicate the frozen rows and columns. The frozen row and column remain 

visible as you scroll throughout the sheet.  

 

To unfreeze something you’ve previously frozen, select View then Freeze then No rows and/or No 

columns. 

 

Formulas 

The distinguishing feature of a spreadsheet program is that it allows you to create mathematical 

formulas and execute functions. Otherwise, it is not much more than a large table for displaying text.  
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Formulas are entered in the sheet cell and must begin with an equal sign "=". The formula then includes 

the addresses of the cells whose values will be manipulated with appropriate operands placed in 

between. After the formula is typed into the cell, the calculation executes immediately and the formula 

itself is visible in the formula bar. See the example below to view the formula for calculating the sub 

total for a number of textbooks. The formula multiplies the quantity and price of each textbook and 

adds the subtotal for each book. 

 

To view the actual formula or function in the cell and its components, double-click on the cell or click 

once and press F2.  Also, if you select the cell, you will see the formula or function for the cell in the 

Formula Bar.    

 

Functions 

Instead of manually typing a formula into the formula bar, you can use the ∑ (Functions) icon on the 

toolbar to insert common functions such as SUM, DATE, AVERAGE, COUNT, MAX, etc.  

 

Activate the cell where the function will be placed and select ∑ from the toolbar. From the functions 

menu you can select a category or view them All alphabetically. As you hover your mouse over a 

function, it provides a brief description of what it does. Click on one to select it. You can also search for a 

function use the search under Help in the menu. 

 

The next step is to choose the cells that will be included in the function. You can do that by clicking on a 

cell, holding down the Shift key, then clicking the cell you want to end at. Notice that it puts them into 

the function separated by a colon. Hit enter and it will calculate and put the result in the cell. Your other 

option is to type the cell addresses right into the function. 

 

Example --   

 =SUM(C2:C6) 

This will add the contents of C2, C3, C4, C5 and C6. 

 
  

Formula Bar 
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Autofill 

The Autofill feature allows you to quickly fill cells with repetitive or sequential data such as 

chronological dates or numbers, and repeated text. 

 

1. Type the beginning number or date of an incrementing series or the text that will be repeated 

into a cell.  

2. Select the handle at the bottom, right corner of the cell with the left mouse button and drag it 

down as many cells as you want to fill.  

3. Release the mouse button.  

4.  

If you want to Autofill a column with cells displaying the same number or date you must enter identical 

data to two adjacent cells in a column. Highlight the two cells and drag the handle of the selection with 

the mouse. 

 

Autofilling Formulas 
Autofill can also be used to copy formulas. In the example below, both column B and column C contain 

numbers. Column D is the total price for that quantity of textbooks. The formula in cell D2 would be 

"=B2*C2” This formula can then be copied to the remaining cells of column D by activating cell D2 and 

dragging the handle down to fill in the remaining cells. The Autofill feature will automatically update the 

row numbers as shown below if the cells are referenced relatively. 

             

 

 

 

 

 

 

 

 

 

Creating Charts 

Charts allow you to present data entered into the sheet in a visual format using a variety of graph types. 

Before you can make a chart you must first enter data into a sheet. Once you have entered data, you 

can select the data and headings in the sheet that you want represented in the new chart. Click on the 

Insert menu option, then select Chart. The Chart Editor will pop up on the right. Select the type of chart 

under Chart Type (Line, Column, Bar, Pie, etc.) 

 

Click on the picture of the type of chart you want to use. 
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Use the options under Setup to define what data to include in your chart and what you want to use for 

headers and labels. Use Customize to change the style, colors and other aspects of the chart’s 

appearance.  

 

Copying or Downloading a Chart 

A finished chart can be copied to be pasted elsewhere. Click on the chart so the three dots appear in the 

upper right-hand corner. Click on the dots. You can either Copy chart to copy it to the clipboard to 

pasted anywhere you like, or you can Download it as a PNG, PDF, or SVG file. 

 

 

Sorting 

Basic Sort  

The Data menu can be used to sort cells in a sheet. To sort by one column, highlight the cells that will be 

sorted and click Data, then Sort sheet by Column X, AZ or Sort sheet by Column X, ZA. AZ will 

either do an alphabetical sort or an ascending number sort, depending on the data in your cells. Note 

that if you instead select Sort range, that it will sort within your column and not take the adjacent rows 

along with your data.  

 

Advanced Sort (Complex Sorts) 

To sort by multiple columns, follow these steps: 

 

1. Highlight the cells, rows, or columns that will be sorted.  

1. Go to Data — Sort Range – Advanced Range Sorting Options. 

2. From the Sort range dialog box, check the box if in your selection your Data has header row.  

3. Then choose the column to Sort by and whether you want it AZ or ZA.  
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4. Click Add another sort column and choose what column you want next in Then by. Add as many 

sort columns as you need. 

 

Themes 

The use of themes in Sheets allows you to quickly format your sheet, provide consistency, and create a 

professional look. Sheets provides several preset themes which include predefined Colors and Fonts to 

enhance the aesthetics of a sheet and its charts. To apply a predefined theme, highlight the cells you 

want to match the theme. Click on Format in the menu, then Theme. You can click on any of the options 

to apply a theme to your selected cells. You can also click the Customize button if you’d like to tweak 

some of the colors or change the font. Theme changes are more obvious if you have created a chart. 

 

Other Resources 

G Suite Learning Center’s Google Sheets Training and Help - 

https://support.google.com/a/users/answer/9282959 

 

Universal Class has a Google Sheets class. You can access Universal Class from our website: 

Explore->eLearning->Universal Class. 

 

https://support.google.com/a/users/answer/9282959

