Microsoft Access 2010

Part 1: Introduction to Database Design

- What is a database?
- Identifying entities and attributes
- Understanding relationships and keys
- Developing tables and other objects
- Planning a database

Part 2: Using Access to Create a Database

- Navigating the Access user interface
- Creating a new blank database
- Understanding object views
- Creating tables and queries
- Designing reports and forms

Part 1: Introduction to Database Design

What is a Database?

A database is 1) an organized collection of electronic data 2) stored in a structure 3) that makes it easy to find information quickly. Microsoft Access is a software program for creating and using databases.

What is the difference between a spreadsheet and a database? Spreadsheets are designed for performing numerical calculations, analyzing limited amounts of data, and sorting lists of items. A database is preferred for long-term storage of large amounts of raw data, especially when certain pieces of the data are repeated multiple times.

Consider the possible problems with storing the following data in a spreadsheet:

<table>
<thead>
<tr>
<th>Agent Name</th>
<th>Agent License #</th>
<th>Agent Phone</th>
<th>House Address</th>
<th>House Price</th>
<th>House List Date</th>
<th>House Foreclosure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Angela</td>
<td>54321</td>
<td>603-555-1212</td>
<td>30 Main St.</td>
<td>$141,000</td>
<td>8/27/2012</td>
<td>Yes</td>
</tr>
<tr>
<td>Angela</td>
<td>54321</td>
<td>603-555-1212</td>
<td>34 State St.</td>
<td>$287,000</td>
<td>6/14/2010</td>
<td>No</td>
</tr>
<tr>
<td>Angela</td>
<td>54321</td>
<td>603-555-1212</td>
<td>56 Oak St.</td>
<td>$112,000</td>
<td>9/20/2013</td>
<td>No</td>
</tr>
<tr>
<td>Angela</td>
<td>54321</td>
<td>603-555-1212</td>
<td>78 Lake St.</td>
<td>$365,000</td>
<td>4/6/2011</td>
<td>Yes</td>
</tr>
</tbody>
</table>

1. Redundant Data: Repetitions take up extra storage space, which slows down the computer’s ability to retrieve information. Also, human time is wasted entering data that is already stored.

2. Data Entry Errors: Repeated entries create more opportunities for human error. Even slight differences between entries can cause problems with sorting and reporting.

3. Editing Data: Updates must be made to every entry of the original data. This takes time, and increases the possibility of data entry errors or overlooking some original entries.

Storing this data in a database would reduce or resolve these issues.
Entities and Relationships

A well-designed database begins with brainstorming a list of the data that will be stored. Items on this list fall into two categories: entities and attributes. An entity is a type of person, thing, event, or location about which you are collecting data. One occurrence of an entity is called an instance. An attribute is a property or characteristic that describes an entity. A single attribute always holds the same kind of data, or data type, such as Text, Number, Date/Time, Yes/No, etc.

<table>
<thead>
<tr>
<th>Entity: Real Estate Agent</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Attribute</strong></td>
<td><strong>Data Type</strong></td>
</tr>
<tr>
<td>- First name</td>
<td>(Text)</td>
</tr>
<tr>
<td>- Last name</td>
<td>(Text)</td>
</tr>
<tr>
<td>- License #</td>
<td>(Number or Text)</td>
</tr>
<tr>
<td>- Phone #</td>
<td>(Text w/special properties)</td>
</tr>
</tbody>
</table>

One Instance:
All data about agent Angela Jones.

<table>
<thead>
<tr>
<th>Entity: House for Sale</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Attribute</strong></td>
<td><strong>Data Type</strong></td>
</tr>
<tr>
<td>- Address</td>
<td>(Text)</td>
</tr>
<tr>
<td>- Price</td>
<td>(Currency)</td>
</tr>
<tr>
<td>- Date listed</td>
<td>(Date/Time)</td>
</tr>
<tr>
<td>- Is it a foreclosure?</td>
<td>(Yes/No)</td>
</tr>
</tbody>
</table>

One Instance:
All data about the house at 12 Main St.

When one entity is connected to another in some way, they have a relationship. A database containing entities that are related is called a relational database. There are three types of relationships possible between entities:

<table>
<thead>
<tr>
<th>One-to-One Relationship</th>
<th>One-to-Many Relationship</th>
<th>Many-to-Many Relationship</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example Entities:</td>
<td>Example Entities:</td>
<td>Example Entities:</td>
</tr>
<tr>
<td>- Husband</td>
<td>- Real Estate Agent</td>
<td>- Movie</td>
</tr>
<tr>
<td>- Wife</td>
<td>- House</td>
<td>- Moviegoer</td>
</tr>
</tbody>
</table>

Each husband has only one wife. Each wife has only one husband.

Each Agent can sell many houses. Each house is sold by only one agent.

( Most common type of relationship )

Each movie can be seen by many moviegoers. Each moviegoer can see many movies.

Planning a Database, Steps 1-3

It’s a good idea to plan your database before you begin to build it. It will be time consuming to make changes to the design of a database after it has been constructed.

1. Identify the separate entities in your data.
2. List the attributes for each entity, and determine their data types.
3. Identify the relationships between entities.
Tables and Keys

A database is a collection of components that work together, like a box with many gears inside it. These components are called objects, and the most important type of database object is a table.

A table is a grid that stores all the data about a single entity. Each attribute of the entity is given one column in the table, called a field. A row contains all the data about a single instance of the entity, and is called a record.

A primary key is a field in which every record’s data is unique, making it easy to positively identify each record. If the table does not include a field like this, multiple existing fields can be used to create a composite primary key, or a new field can be added to serve as a primary key. The primary key is most often a Number field, but can also be Text or some other data type.

When entities are related, a record in one table must be able to refer to the appropriate record in the other table. To establish a relationship, the referring table will include a field called a foreign key, which stores the primary key value of the correct record from the candidate table. For this to work, the data type must be the same for both fields, since they hold the same data.
The concept of **referential integrity** keeps data consistent by prohibiting you from referring to a nonexistent record, preventing you from deleting a record if references to it exist, and updating all references to a record when it is modified. You can choose to ignore or enforce data integrity.

**Planning a Database, Steps 4-6**

In a well-planned database, the entities you have identified will translate neatly to tables.

4. Plan one table for each entity, with a field for each attribute.
5. In each table, identify the field that will serve as the primary key, or add one if necessary.
6. For each relationship, ensure that the referring table includes a field to serve as the foreign key, and that it has the same data type as the primary key field to which it refers.

**Other Database Objects**

After tables, the other three common objects are queries, reports, and forms.

A **query** is a command to the database that retrieves data matching criteria you define. With a query, you can view or manipulate a selected subset of the data stored in a single table or multiple related tables. Reports and forms access data stored in tables by using queries to filter what is displayed. Queries look similar to tables, as both objects display raw data in a grid.

A **report** is a graphical object that presents data in a formatted layout. This is useful for displaying data in an organized manner, and for printing. Reports can also group and sort data, perform and display calculations, and produce charts. Because a report is a graphical object, you have a great deal of design control over the formatting and layout of elements that are displayed.

A **form** is a graphical object that acts as an interface between a user and the tables where data is stored. With forms you can view, edit, input, and delete records stored in tables. Forms also create a buffer to prevent users from altering the design of tables while accessing data. You can also create forms that have no data source but which perform other tasks. Like reports, forms give you wide control over the graphical design and presentation of form elements.

Less common objects, which are not discussed in this class, include:

- **Pages**: HTML Web pages that provide access to your database via the Internet.
- **Macros**: Programmed sets of commands, usually used to automate repetitive tasks.
- **Modules**: Instructions in programming code, which modify the behavior of other objects.
Planning a Database, Steps 7-9

Take time to brainstorm other objects you will need. This may lead you to revise your tables.

7. Think about who will use the database, and for what tasks. Make a list of forms those users will need for their work, and determine what data each form will need to access.
8. Think of the results you will need to review or produce. Make a list of reports that will display those results, and determine what data each report will need to draw from.
9. Make a list of queries to create the subsets of data needed by your forms and reports.

Part 2: Using Microsoft Access to Create a Database

Creating a New Blank Database

When you first open Access, you are on the File tab (also known as Backstage view), where you can create a new database or open and save an existing database.

To create a new database from the File tab:

1. In the left side pane, click New.
2. In the center pane, click once on Blank Database.
3. In the right pane, under File Name, type a name for your database.
4. To change the location on the computer where the database will be saved, click the folder icon, browse to the desired location, and click OK.
5. Click the Create button.

Microsoft Access User Interface

The user interface includes four areas:

1. The Ribbon: This area across the entire top of the screen gives you access to tools and commands, which are grouped onto several tabs. Additional tabs appear when you are working on an object; the tools on the new tabs are relevant to that type of object.
2. The Quick Access Toolbar: Located above the ribbon in the left corner, this is a customizable toolbar with shortcuts to a small number of tools.
3. The Navigation Pane: On the left side of the screen you are shown a list of all the objects in your database, organized by object type. Double click an object to open it, or right click an object to see a menu of other possible commands.
4. The Main Workspace: The main area displays the object you are currently working on. The name of the object appears on a tab at the top of the workspace. When multiple objects are open, you can switch between them by clicking the name tabs.
Views

There are multiple ways to view an object in Access. These can be divided into views where you modify the design of the object, and views where you use the object for its intended purpose. The tool for switching views is on the far left of the Home tab. The icon (picture) on the Views tool changes when you switch views. That icon always shows the view you will switch to when you click it. You can also select different views by clicking the arrow below the word Views.

Creating Tables

Tables have two basic views: Design View, where you prepare your table to receive data by setting up fields, and Datasheet View, where you enter and view data stored in the table.

Design View

1. Create the table. On the Create tab, click Table Design to begin in Design View.
2. Save the table. On the Quick Access Toolbar, click the Save icon. You will be prompted to name your table. Click OK.
3. Create fields. List the fields you have planned for this table in the grid provided.
   - Field Name: Give each field a name. Keep it as short but descriptive as possible.
   - Data Type: Use the dropdown list to select a data type for each field.
   - Description: Write a description of the field for future reference by you or others.
4. Assign a primary key. Select the field that will serve as the table’s primary key. On the Design tab, click the Primary Key tool.
5. Establish relationships. If a field will look up its values in another table, select it and change the data type to Lookup Wizard. A popup will walk you through the process of establishing the relationship.
   - The candidate table must be closed first for this to succeed.
   - When prompted to select fields, select the candidate table’s primary key field, as well as any other fields that will help you choose the correct record during data entry. The primary key data will be stored, but you can choose to hide it. Only the data from the additional fields will be displayed in the lookup dropdown list.
   - On the final screen, check the box beside Enable Data Integrity to ensure that referential integrity is preserved.
6. Modify field properties. Fine-tune a field by selecting it and adjusting its properties in the bottom half of the screen. The properties available will vary depending on the field’s data type. To learn about any property, select it and press the F1 key on your keyboard.
7. Save changes. Click the Save icon on the Quick Access Toolbar.
Datasheet View

To create a new record, just start typing data in the blank row provided. Press the Enter or Tab key to move to the next field. You do not need to save your data; it is saved automatically once you leave the record (by moving to a different record or leaving the object).

It is possible to create new fields in Datasheet View. Locate the last column on the right, and click on the words Click to Add. You must first select a data type, then type a name for your field. Note that you will be unable to add a description or modify the field properties without switching to Design View.

Tables in Datasheet View can be manipulated similar to an Excel spreadsheet. You can adjust the column width and row height, filter and sort records to view them differently, and search through records.

Creating Queries

Queries have two basic views: Design View, where you select criteria for the data that your query will search for, and Datasheet View, where you view and modify the data your query identifies. In Design View the workspace is divided into two sections: the Object Relationship Pane above, and the Design Grid below.

1. Create the query. On the Create tab, click Query Design to begin in Design View.
2. Select tables. In the Show Table popup, select the tables that contain the data you want, and click Add. When you have added all the tables you need, click Close. You will see representations of your tables in the Object Relationship Pane.
3. Save the query. On the Quick Access Toolbar, click the Save icon. You will be prompted to name your query. Click OK.
4. Select fields. In the Object Relationship Pane, locate the fields that contain the data you want. Double click each desired field to add it to the Design Grid below.
5. Reorder fields. To change the order of fields in the Design Grid, click and drag the grey bar at the top of a field.
6. Set search criteria. In the Design Grid, use the Criteria row for each field you want to filter. Type the criteria or conditions you want to apply to that field. The results of your query will show only the records that match your criteria in the filtered fields.
   - Conditional operators (>,<, =, >=, <=) limit numeric fields. Ex: “<5” (less than 5)
   - = filters text fields. Ex: “=NH” (field contains “NH”)
   - And combines two filters. Ex: “>2 And <7” (greater than 2 and less than 7)
   - Use the Or row for alternative filters. Ex: “=3” Or “=6” (field contains 3 or 6)
   - Use * as a wildcard. Ex: “=B*” (field contains any value starting with “B”)
   - If you filter a field but don’t need it to display in the results, uncheck Show.
7. **Sort the data.** To sort a field, use the dropdown list in its **Sort** row. If you sort more than one field, Access determines the sort order from left to right.

8. **Save changes.** Click the **Save** icon on the **Quick Access Toolbar**.

9. **View the results.** Switch to **Datasheet View**, or click the **Run** tool on the **Design** tab.

This type of query is called a **select query**, because it selects a subset of data without making changes. Other types of queries not discussed in this class include: queries that find duplicate records, find records with no corresponding records in other tables, do calculations, and perform actions such as deleting or modify sets of records, adding new records, or creating new tables.

**Creating Reports and Forms**

In Access, reports and forms have many similarities. Both are graphical objects that must be designed visually as well as structurally. Reports and forms have three basic views: **Design View** and **Layout View**, both of which allow you to modify the object’s graphic design, and **[Object] View**, which shows the object in its useable form. **Report View** displays a report in its printer friendly state. **In Form View**, a form can be used to view, modify, and enter data.

Reports and forms contain **controls**, which are visual elements used to display information or interact with the object. These include controls that display or receive data stored in tables (such as textboxes, dropdown lists, or checkboxes), controls that display other information (such as report titles or field labels), and controls that perform an action (such as buttons). Controls can be **bound** (tied to a field in a table or query), or **unbound** (not tied to an existing field).

**Creating Reports**

1. On the **Create** tab, click the **Report Wizard** tool.
2. From the dropdown list, choose a table or query that contains data you want to report. Select the relevant fields from that object. Click **Next**.
3. On the next two screens, decide how to group and sort data on your report. Click **Next**.
4. Select a layout and page orientation for your report. Click **Next**.
5. Type a name for your report, and click **Finish** to view the report in **Print Preview**.
6. Click **Close Print Preview** to view the report in **Design View**.

**Creating Forms**

1. On the **Create** tab, click the **Form Wizard** tool.
2. Choose the table your form will access. Select the fields that will display. Click **Next**.
3. Select a layout for your form. Click **Next**.
4. Type a name for your form, and click **Finish** to view the report in **Form View**.
Alternative Methods for Creating Reports and Forms

To quickly generate a simple report or form, in the Navigation Pane click on the table or query that will be the data source. Then, on the Create tab, click the Report or Form tool.

To create blank reports and forms, on the Create tab click the Report Design or Form Design tool (begin in Design View), or the Blank Report or Blank Form tool (begin in Layout View).

Modifying Reports and Forms

Reports and forms have two views in which you can make changes. In Layout View you can adjust elements of the design while viewing data as it will appear in the final object. In Design View, the underlying data is not displayed, but you have a more detailed view of the structure of a report or form. In Design View, you have some options that are unavailable in Layout View.

In both views you can:

- Change the theme. On the Design tab, use tools in the Themes group to change the look of your report or form.
- Adjust the layout. Use tools on the Arrange tab to change the position of controls.
- Move / resize controls. Click and drag controls to move them. To resize a control, select it then click and drag its border. To remove a control, select it and press the Delete key.
- Add bound controls. On the Design tab, in the Tools group, click the Add Existing Fields tool to display the Field List. Drag a field onto the object to add it as a control.
- Add unbound controls. On the Design tab, in the Controls group, click on the type of control you wish to add. Click the report or form to place the new control.
- Fine-tune control properties. On the Design tab, in the Tools group, click the Property Sheet tool to display the Property Sheet. Select a control from the dropdown list and edit its properties. To learn about any property, select it and press the F1 key.
For More Information about Microsoft Access

Books at NPL

The Library also has several books on Microsoft Office 2010, which contain sections on Access, as well as books on the newest edition: Access 2013.

Free Online Resources

Microsoft’s help files for Access 2010. Click on “see all” to view more categories.

[http://www.gcflearnfree.org/access2010](http://www.gcflearnfree.org/access2010)
Goodwill Community Foundation’s excellent online tutorials for Access 2010. Offering free lessons with accompanying downloadable practice databases.

Courses in the Nashua Area

Several schools and training companies in the area offer Microsoft Access classes. Prices vary. A few are listed below, but this list is not intended as an endorsement by the Library.

[http://www.adultlearningcenter.org/computer-technology/](http://www.adultlearningcenter.org/computer-technology/)
Adult Learning Center

Business Computer Skills

[http://www.nashuacc.edu/academic/programs-of-study/certificate-programs?id=78](http://www.nashuacc.edu/academic/programs-of-study/certificate-programs?id=78)
Nashua Community College

New Horizons Computer Learning Centers

[http://www.onlc.com/training/access/nashua-nh.htm](http://www.onlc.com/training/access/nashua-nh.htm)
ONLC Training Centers